Mountain Lion und das Wifi-/WLan-Problem – endlich gelöst!?

Mountain Lion und das Wifi-/WLan-Problem – endlich gelöst!?

Nachdem das heiß erwartete Update 10.8.3 nun doch noch recht lange in der Entwickler-Pipeline steckte, war ich umso hoffnungsvoller, dass nun auch endlich das lästige iMac-WLan-Problem gelöst wäre.

Beim Lesen der Release-Notes machte sich bei mir jedoch schnell Ernüchterung breit – wie schon bei den Vorgängerversionen nicht ein Wort zum (folgt man den Beiträgen hierzu in diversen Userforen) inzwischen vermutlich auch Apple bekannten Bug. Das am Tag des Erscheinens direkt aufgespielte Update brachte die Bestätigung: leider nix Neues, die Strippe quer durch die Wohnung bleibt bis auf Weiteres …

Oder doch nicht? Nachdem ich mich schon mal mit einem Lösungansatz für die Mac-Seite des Problems aus dem Fenster gehängt hatte, muss nun etwas neues her. Also noch mal scharf nachdenken und recherchieren: Da das Problem in Deutschland häufig Nutzer von Speedport-Routern – und hier an vorderer Stelle Besitzer des W 723 V – betrifft, packe ich’s mal von dieser Seite an. Wenn man das Heim-Netzwerk mal mit einem Tool wie iStumbler durchleuchtet, stellt man fest, dass der Router als “AVM” identifiziert wird, also nichts anderes als eine “Fritzbox” mit Telekom-Firmware ist. Auch von der Kombination Mac mit Fritz-Routern sind die Probleme mit den WLan-Abbrüchen bekannt.

Vielleicht liegt es also am Übertragungsprotokoll des Routers, mit dem der iMac nicht zurecht kommt. Irgendwo in einem dieser Endlos-Threats hatte ich bereits gelesen, es würde helfen, wenn man das Übertragungsprotokoll  IEEE 802.11b ausschließt. Und ebenso vielversprechend scheint mir dieser Ansatz aus den Niederlanden der übersetzt in etwa lautet:

“Der Hersteller meines Routers (einer Fritzbox 7360, sehr beliebt hier in Europa) hat mir geraten, die Kanäle 12 und 13 zu auszuschalten und die Kanäle, die für 300 Mbit/s optimiert sind, zu deaktivieren, … , weil, und ich zitiere: “Verschiedene WLAN-Geräte oder Adapter können mit diesen Kanäle nicht so gut klarkommen.” Was in unserem Fall bedeuten würde, dass bestimmte WiFi-Karten in unseren Macs nicht dazu gebaut wurden, bestimmten Anforderungen zu entsprechen. Ich habe die Atheros WLAN-Karte (mit 4,0 Firmware-oder Software, 3.x ok) in meinem Mitte-2011-iMac schon längere Zeit im Verdacht, aber niemand scheint dem zuzustimmen, insbesondere Apple nicht. Sie schweigen.”

Da die Telekom-Firmware derartiges “Fine-Tuning” nicht hergibt, habe ich diese Erkenntnisse für unsere konkrete Kombination aus iMac Mitte 2012 und Speedport W723 V (Rev. b) dann wie folgt umgesetzt:

– Übertragungsmodus: 802.11a + 802.11n
– Geschwindigkeit: max. 300 Mbit/s deaktiviert
– Sendeleistung und Wahl eines festen Kanals optional

Und voilà: Seitdem läuft hier alles stabil und sehr, sehr schnell, keine Abbrüche mehr …